Reply
 
Thread Tools Display Modes
 
Old 07-12-2018, 01:06 AM   #1
Platinum Member
 
Join Date: Aug 2017
Location: CA
Posts: 423
Default High pressure hose on power steering pump?

Question; have any of you had a failure on your Mercedes Benz Sprinter with the "power steering pump" around 50,000 miles??? It's on the 3 litre V6...

I know someone who has a Winnebago Via and this happened to him between 45,000 and 50,000 miles....

Maybe it's just "bad luck"...or is this a wider problem???

I'm going to have all of my hoses on the Roadtrek checked out before I go back across the USA... but, it would be definitely good to know if you've heard anything about problems cropping up like that....
__________________

Roadtrek Adventuous RS1 is offline   Reply With Quote
Old 07-12-2018, 01:11 AM   #2
BBQ
Platinum Member
 
Join Date: May 2016
Location: East
Posts: 2,326
Default

.

Have you checked with the http://sprinter-source.com/forum/ ?
__________________
BBQ is online now   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3

All times are GMT. The time now is 07:29 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2018, vBulletin Solutions, Inc.