Reply
 
Thread Tools Display Modes
 
Old 05-03-2019, 10:55 PM   #1
New Member
 
Join Date: Dec 2016
Location: mi
Posts: 2
Default Power awning wont open

I have a 2016 winnebago sprinter era. Awning wont open (used to work fine altho never really used). Power button lights up when held down but no motor startup sound. Any suggestions?
__________________

Trudy is offline   Reply With Quote
Old 05-03-2019, 11:41 PM   #2
Platinum Member
 
rowiebowie's Avatar
 
Join Date: Jul 2018
Location: Texas
Posts: 1,087
Default

12v fuse blown? Maybe power to the switch but not to the awning? Check coach fuse box and consult your owner's manual. Good luck.
.
__________________

rowiebowie is offline   Reply With Quote
Old 05-04-2019, 12:14 PM   #3
Bronze Member
 
Join Date: Dec 2018
Location: Michigan
Posts: 21
Default

I'm having the same issue on a 2019 Travato. Retract button was accidentally hit when the awning was already fully retracted and blew the fuse. I replaced the fuse but now there is no motor noise when I engage the switch. I wonder if there is another fuse somewhere that I don't know about that needs to be changed. It's a Colorado Carefree unit. Anyone have any insight?
Chris Hayden is offline   Reply With Quote
Old 05-05-2019, 12:15 AM   #4
Platinum Member
 
rowiebowie's Avatar
 
Join Date: Jul 2018
Location: Texas
Posts: 1,087
Default

You both have new or fairly new Winnebago units. You should probably call the Winnebago home office customer support. They may refer you to the awning manufacturer, but I'd start with the coach builder.

Good luck.
.
rowiebowie is offline   Reply With Quote
Old 05-05-2019, 11:44 AM   #5
Bronze Member
 
Join Date: Nov 2018
Location: Nantucket
Posts: 43
Default

I would start my turning off the house disconnect switch to reset the computer that controls everything. Next I would try opening the awning from the touch screen panel.

You can scroll through the fuses by using the control arrows on the front of the control panel above the fuses. Much easier than pulling each one. On my Era 170A this is under the driver side bed.

If all else fails call Winnebago tech support as they are a huge help. They walked me through everything for diagnosing a bad touch screen panel and sent me a new one that I installed.
magicbus is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3

All times are GMT. The time now is 12:51 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
×