Reply
 
Thread Tools Display Modes
 
Old 01-01-2016, 10:55 PM   #1
New Member
 
robp2001's Avatar
 
Join Date: Jun 2015
Location: Lancaster, SC
Posts: 7
Default Truma combi smell

I have a Winnebago Travato with a truma combi. When I use the electric elements I get an electrical smell in the coach. When I switch to gas the smell goes away after some time. This has happened both times I used the electric only settings. Anybody else experience this issue

Thanks
Rob
__________________

robp2001 is offline   Reply With Quote
Old 01-01-2016, 11:04 PM   #2
Site Team
 
avanti's Avatar
 
Join Date: Jul 2013
Posts: 3,267
Default

I don't have a Truma, but the same thing happens when I use the electric heating element in my air conditioner. I think it is just dust and stuff burning off the heating elements. I bet it will go away after awhile
__________________

__________________
Formerly: 2005 Airstream Interstate (Sprinter 2500 T1N)
Now!: 2014 Great West Vans Legend SE (Sprinter 3500 NCV3 I4)
avanti is offline   Reply With Quote
Old 01-01-2016, 11:04 PM   #3
Platinum Member
 
Bruceper's Avatar
 
Join Date: Jul 2014
Location: Manitoba
Posts: 635
Default

I would suspect that the elements are burning off a coating of some kind.
Bruceper is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3

All times are GMT. The time now is 11:43 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2019, vBulletin Solutions, Inc.