Reply
 
Thread Tools Display Modes
 
Old 05-27-2011, 10:47 PM   #1
New Member
 
Join Date: Jul 2010
Posts: 3
Default Generator cuts off



My Rialta is a 2005 model. The Onan generator cuts off after about 20 minutes. It runs real smooth for about 15 minutes, then it starts surging, then finally quits. After a cool off period it will restart. I have gone thru the manual trouble shooting, oil level, spark plug, fuel in tank etc. I cannot find the problem. Any Suggestions?


Sid Fortney



__________________

sfortney is offline   Reply With Quote
Old 08-22-2011, 05:57 PM   #2
New Member
 
Join Date: Jul 2010
Posts: 3
Default Generator cuts off



After about $500 of expenses at 2 Onan service centers, the problem was the fuel pump. The carb was also chnaged but that did not fix the problem until the fuel pump was changed. The pump was bench tested for pressure and flow and found to be defective. It cut off completely at running temp. I had the same thing happen with another small 4 cycle engine. I think the problem stems from gas with ethanol. Several mechanics have told me that the ethanol is ok as long as the engine is running. However when sitting it starts to work on the internal components of the pump. I think God intended ethanol for drinking and not for internal combustion engines! However, I don't even drink it! SF

__________________

sfortney is offline   Reply With Quote
Old 08-23-2012, 07:43 PM   #3
New Member
 
Join Date: May 2012
Posts: 10
Default Generator cuts off



Sid,



I've had the same issue with the Onan on our 2002 Rialta. After $$$ to replace the carburator and voltage regulator, the generator starts fine and runs for about 20 minutes, then starts surging for about 2-3 minutes, and stops. It will restart after approximately 30 minutes. I've ordered the Onan Service Manual so I can locate the fuel pump. Is its replacement a handyman-level job, or should I take it in once again for that service? If they need to pull the engine - once again! - this could be big bucks.



Best regards,



Bill Blask

Bblask75 is offline   Reply With Quote
Old 09-01-2012, 05:54 PM   #4
New Member
 
Join Date: May 2012
Posts: 10
Default Generator cuts off



Good news! With an engineer friend I experimented with ice held on the fuel pump as the generator ran, since after the generator had once again surged and then stopped the fuel pump seemed unexpectedly hot. While the ice was held against the pump the generator kept running! When the ice was removed, five minutes later the generator again surged and stopped. Diagnosis: defective fuel pump.I ordered Onan part # A029G426 Pump – Fuel for our 2002 Rialta Onan KVC Spec – B generator from Jack's Small Engines in Jarrettsville, MD ($56 plus shipping). After installation, the surging/stopping problem was gone: the generator ran until I shut it down after an hour. Moreover, I was able to restart the generator immediately, where before at least 20-30 minutes would have to elapse before the unit would restart.



Many thanks to member SFortney for sharing his problem and solution.

Bblask75 is offline   Reply With Quote
Old 01-21-2013, 02:58 AM   #5
New Member
 
Join Date: Jan 2013
Posts: 3
Default Generator cuts off


Bblask75 said:

Sid,



I've had the same issue with the Onan on our 2002 Rialta. After $$$ to replace the carburator and voltage regulator, the generator starts fine and runs for about 20 minutes, then starts surging for about 2-3 minutes, and stops. It will restart after approximately 30 minutes. I've ordered the Onan Service Manual so I can locate the fuel pump. Is its replacement a handyman-level job, or should I take it in once again for that service? If they need to pull the engine - once again! - this could be big bucks.



Best regards,



Bill Blask




billbinarv is offline   Reply With Quote
Old 01-21-2013, 03:00 AM   #6
New Member
 
Join Date: Jan 2013
Posts: 3
Default Generator cuts off


billbinarv said:
Bblask75 said:

Sid,



I've had the same issue with the Onan on our 2002 Rialta. After $$$ to replace the carburator and voltage regulator, the generator starts fine and runs for about 20 minutes, then starts surging for about 2-3 minutes, and stops. It will restart after approximately 30 minutes. I've ordered the Onan Service Manual so I can locate the fuel pump. Is its replacement a handyman-level job, or should I take it in once again for that service? If they need to pull the engine - once again! - this could be big bucks.



Best regards,



Bill Blask



bill you stated you ordered manual for generator where did you order thanks billbinarv
bbrads2655@bellsouth.net any info would help??


billbinarv is offline   Reply With Quote
Old 02-09-2013, 10:03 AM   #7
New Member
 
Join Date: Apr 2010
Posts: 6
Default Generator cuts off



Same Onan shutdown problem on my 2003 HD. Thanks, gentlemen for your input. How about a run thru on locating and replacing said errant pump?


Bill

__________________

wmwlow is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3

All times are GMT. The time now is 07:54 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
×