Reply
 
Thread Tools Display Modes
 
Old 06-19-2013, 08:10 PM   #1
New Member
 
Join Date: Jun 2013
Posts: 5
Default Water Pump randomly stopped working...



Only had my '97 Rialta RC for a week. All water faucets were working and the water pump was working.



I filled the fresh water tank for the first time today. I opened the faucets (hot and cold) for a while until there was a weak stream coming through. I turned on the water pump and got a good stream out of the kitchen. I didn't do the shower at this point (read the manual AFTER and realized maybe I should have...).



Steaming hot water was coming out of the kitchen faucet. I let hot and cold run for about a mnute. Turned off the cold, then turned off the hot. Not sure exaclty what happened, but when I went to check my tank levels and battery capacity, the meter wasn't working - the breaker had popped a fuse, popped, whatever you call it. Pushed the fuse for the water pump/lights back in and tried again. Water pump tried to turn on but shut off and then the fuse popped again. Tried a couple more times, now the pump doesn't even try to turn on.



Any ideas what happened or where to begin diagnosing? Strange that the water pump was working strong and then failed randomly. The pump was turning on and off automatically as it should before it failed.




newuserguy is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3

All times are GMT. The time now is 01:22 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2018, vBulletin Solutions, Inc.