Reply
 
Thread Tools Display Modes
 
Old 06-18-2020, 06:54 AM   #1
New Member
 
Join Date: Dec 2019
Location: CA
Posts: 2
Default 2016 Roadtrek RS

We have a 2016 Roadtrek RS with Ecotrek and recently replaced the two 6 volt house batteries. Now, there is no electrical power inside the cabin, no refrigerator, no microwave, no lights. Even the Ecotrek panel doesn't show the blue light anymore. Since the Sprinter has a separate battery for the engine, I have no trouble starting the engine. I was looking for a fuse but can't find it. Does anyone have similar experience with their Roadtrek? Thanks.
__________________

elmonewport is offline   Reply With Quote
Old 06-18-2020, 02:37 PM   #2
Platinum Member
 
rowiebowie's Avatar
 
Join Date: Jul 2018
Location: Texas
Posts: 1,756
Default

Quote:
Originally Posted by elmonewport View Post
We have a 2016 Roadtrek RS with Ecotrek and recently replaced the two 6 volt house batteries. Now, there is no electrical power inside the cabin, no refrigerator, no microwave, no lights. Even the Ecotrek panel doesn't show the blue light anymore. Since the Sprinter has a separate battery for the engine, I have no trouble starting the engine. I was looking for a fuse but can't find it. Does anyone have similar experience with their Roadtrek? Thanks.
Welcome to the forum elmonewport!

There are a variety of Etrek owners here (I'm not one). Pretty sure one will be along to help you. I did not know any Etrek models had just two batteries. And I thought the blue Etrek panels were for lithium models. I will watch and learn.
__________________

rowiebowie is offline   Reply With Quote
Old 06-25-2020, 04:50 PM   #3
New Member
 
Join Date: Jun 2020
Location: NC
Posts: 4
Default

I'm going through the exact same issue with my 2016 RS Adventurous. Shop told me that one of the 6 volt under hood batteries was dead, so we are about to put 2 new ones in. I'll keep you posted on how things go with me...please do the same.
southernstar@usa.net is offline   Reply With Quote
Old 07-02-2020, 08:29 PM   #4
New Member
 
Join Date: Dec 2019
Location: CA
Posts: 2
Default

Thank you for your email. It appears that you are dealing with the same issue, as you mentioned. I had one of the two 6 volt battery (golf cart battery) not charging properly and with Covid 19, we were not driving much. So, we ended up replacing both 6volt battery. Once we did that, we realized that the lithium battery is not working. As you know, lithium battery is charged 3 ways, using the solar, under the hood generator and shore power. If the coach battery (two 6 volt batteries) doesn't work properly, I think it impacts the lithium battery as well. Solar panel and under the hood generator switch are powered by the coach battery. We are trying to figure out if the under the hood generator is working properly or the lithium battery is damaged. Once we trickle the lithium battery, all the power inside the cabin comes back but will shut down within a few minutes since lithium battery is drained or damaged. We are trying to figure out the lithium battery. According Roadtrek, we need to reset the lithium battery. Will let you know. Meanwhile, we are trying to install a solar battery charger for the two 6 volt battery.
elmonewport is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3

All times are GMT. The time now is 08:12 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
×