RV News RVBusiness 2021 Top 10 RVs of the Year, plus 56 additional debuts and must-see units → ×
 
 


Reply
 
Thread Tools Display Modes
 
Old 01-07-2021, 06:51 PM   #1
New Member
 
Join Date: Mar 2018
Location: TN
Posts: 19
Default Is it the clutch cable?

I have a RT Zion on a Promaster 2017 chasis. Recently the van 'dropped' into neutral when I tried to pull away from a stop sign. It corrected quickly. I know that something called a clutch cable had been recalled. I contacted my Dodge dealer to see if my part was in. He said my cable was not in, but he would give me someone else's cable since I was experiencing the problem. The part was replaced. That was several weeks ago. Now, again when stopped at a traffic light, my van again 'dropped' into what I guess was neutral and I couldn't accelerate. I turned the van off and then restarted and had no further problem. Has anybody else experienced this type of problem? Thanks --
__________________

Reiko is offline   Reply With Quote
Old 01-08-2021, 12:10 AM   #2
Platinum Member
 
rowiebowie's Avatar
 
Join Date: Jul 2018
Location: Texas
Posts: 2,106
Default

An odd name for a part on an automatic transmission vehicle. Unless, you have one of the extremely rare diesel engines with the dual-clutch automated transmission.
__________________

rowiebowie is offline   Reply With Quote
Old 01-08-2021, 08:52 PM   #3
Platinum Member
 
Join Date: Aug 2020
Location: Little Valley NY
Posts: 187
Default

https://www.automotive-fleet.com/349...-shifter-cable
__________________
2008 Roadtrek 210V
Formerly:
Toyota Sunrader
Tiffin Allegro
Foretravel U225
wny-pat is offline   Reply With Quote
Old 01-09-2021, 09:26 AM   #4
New Member
 
Join Date: Mar 2018
Location: TN
Posts: 19
Default

Thanks for identifying the part. My attempt was slightly above labeling it "thingy".
Reiko is offline   Reply With Quote
Old 01-09-2021, 09:29 AM   #5
New Member
 
Join Date: Mar 2018
Location: TN
Posts: 19
Default

I'm very clumsy at this technical stuff. No, I don't have a diesel. I think WNY-Pat has correctly identified what I'm talking about.
Reiko is offline   Reply With Quote
Old 01-09-2021, 05:23 PM   #6
Platinum Member
 
rowiebowie's Avatar
 
Join Date: Jul 2018
Location: Texas
Posts: 2,106
Default

Sounds like you'll be ok, now that you are aware of the problem. Just be careful when engaging transmission until yours gets fixed.
rowiebowie is offline   Reply With Quote
Old 01-11-2021, 09:36 AM   #7
New Member
 
Join Date: Mar 2018
Location: TN
Posts: 19
Default

Thank you!
Reiko is offline   Reply With Quote
Old 01-11-2021, 04:45 PM   #8
Platinum Member
 
Join Date: Feb 2015
Posts: 1,312
Default

We haven't had anyone report this situation over on the Facebook page for Zion/Simplicity owners. But we have had reports of early replacements of transmissions. I would definitely take this into a Promaster dealer so there is a history in your files just in case it completely fails on you.

You might head over to the Promaster forum and see if anyone over there has had the issue and/or diagnosed it.

https://www.promasterforum.com/forums/
__________________
Mumkin
2019 Roadtrek Simplicity SRT (almost a Zion)
2015 Roadtrek 170
2011 LTV Libero
2004 GWV Classic Supreme
mumkin is offline   Reply With Quote
Old 01-12-2021, 09:33 AM   #9
New Member
 
Join Date: Mar 2018
Location: TN
Posts: 19
Default

Thanks. I have an appointment today with the dealer who replaced the cable the first time.
__________________

Reiko is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3

All times are GMT. The time now is 06:32 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
×