Class B Forums

Class B Forums (https://www.classbforum.com/forums/)
-   Electrical | Charging, Systems, Solar and Generators (https://www.classbforum.com/forums/f23/)
-   -   Roadtrek house batterys not charging while driving (https://www.classbforum.com/forums/f23/roadtrek-house-batterys-not-charging-while-driving-11603.html)

jimtwilliams1226 12-20-2020 08:22 PM

Roadtrek house batterys not charging while driving
 
My 2007 Roadtrek SS Agile house batteries will not charge while driving. They will full charge when plugged into 110v power. While checking the elec diagram I noted a Battery separator and several breakers. Where is the battery separator located? Any info on trouble shooting the charging issue is welcome.

daveamaro 01-03-2021 06:54 PM

Sounds like the problem I had with my 2008 Adventurous. On a long trip we started having very heavy charging at night. The problem turned to be a bad separator.

A voltmeter reading confirmed the problem was with the separator. The separator was failing to close and tie the house batteries to the charging system with the engine running. A correctly separator will drop to zero volts different between the two main terminals. My separator is located on the firewall.

Looking for my notes on this.

joeski 01-03-2021 07:13 PM

I had a bad circuit breaker in the transfer switch elec compartment on my RT190. Check the voltage across the terminals, they should be pretty close .

Pam G 01-04-2021 12:21 AM

Quote:

Originally Posted by jimtwilliams1226 (Post 122378)
My 2007 Roadtrek SS Agile house batteries will not charge while driving. They will full charge when plugged into 110v power. While checking the elec diagram I noted a Battery separator and several breakers. Where is the battery separator located? Any info on trouble shooting the charging issue is welcome.

I have a 1999 RT 190P so my diode isolator (battery separator) may not be in the same location as yours. Mine is under the hood right in the middle at the back top of the engine compartment (under the back of the hood). My diode isolator went bad too a couple of years ago. Something else you may need to check - after I had it replaced, the coach battery still wasn't getting charged. There is a circuit breaker between the diode isolator and the coach battery. In my RT, the circuit breaker is separate from the other fuses/circuit breakers and was behind the panel. It had burnt out. I was able to replace it myself. I'm sure yours is probably in a different location though.

lomcevok 01-04-2021 03:36 PM

The battery separator relay is on the firewall just above and to the left of the engine (in front of the passenger seat). It looks like a big solenoid with large wires going to it and one small wire that enables it. (This wire can be connected and disconnected easily to test the relay).

As a first step, make sure your engine driven alternator and battery are above 13.5V as this is the trip voltage for the relay to close and connect both batteries to the engine-driven charge circuit.

Rocinante 01-04-2021 03:46 PM

I have a similar issue with my Airstream Interstate. We tried replacing the stock battery combiner / isolater with a Victron Cyrix unit, but it was unable to connect when the engine was running. Our installer said he's seen this before but the cause is unknown (squirrely smart alternator?) and when it happens it drives him crazy trying to figure out what's going on.

We're now investigating replacement of the battery combiner / isolator with a smarter DC to DC converter like Victron's Orion product line. Maybe this one: https://www.victronenergy.com/dc-dc-...orion-tr-smart
We haven't done that yet, but we're hoping it will solve our problem.

If that doesn't work, we may have to look at replacing our alternator with one whose "smart" capabilities work as expected, whatever those are. If we do, we'll put in the biggest, baddest, smartest alternator that will fit in our Sprinter 3500.

reilym 01-06-2021 02:07 PM

2 Attachment(s)
Quote:

Originally Posted by jimtwilliams1226 (Post 122378)
My 2007 Roadtrek SS Agile house batteries will not charge while driving. They will full charge when plugged into 110v power. While checking the elec diagram I noted a Battery separator and several breakers. Where is the battery separator located? Any info on trouble shooting the charging issue is welcome.

We had the same problem when we bought our used 2016 PW Lexor - the coach batteries were not charging while driving. It turns out that the 150 amp fuses between the separator and the chassis batteries were blown. These were located under the hood, inline with the red charging cables (on the left in the photo) going from the separator to the coach. After replacing the fuses, I discovered that the separator was not working and so I replaced it. If you have a solenoid based separator like is in out Lexor (SurePower 1314-200), you should hear it click closed a few seconds after starting the engine as the voltage goes above 13.2 volts. That is an indication that the chassis and coach batteries are connected and both charging from the alternator. A few seconds after turning off the engine you should hear it click open as the chassis battery voltage drops below 12.6 volts, effectively separating the battery banks. I suspect that someone accidentally shorted something to the chassis before we purchased the RV, damaging the separator and blowing the fuses.

All that said, I have replaced the separator with a Cole-Hersee 75920 manual disconnect switch and am using a Renogy 60 amp DC-DC charger, managed by a slick device I learned about on this forum. This set up reduces the total current load placed on the alternator and maintains the automatic switching based on alternator operation. With the old set up, when the LiFePO4 batteries were depleted it would be common to have 150 amps going from the alternator to the coach and now that maxes out at about 75 amps and I can limit to half that if necessary. I leave the manual switch closed (on) unless the unit is in storage, when I turn it off to completely isolate the chassis battery from the coach.

wny-pat 01-08-2021 10:04 PM

Quote:

Originally Posted by Pam G (Post 122891)
I have a 1999 RT 190P so my diode isolator (battery separator)

They are two different items which serve the same purpose. Roadtrek switched from a isolator to a separator around 2007/08. The separator is generally considered the better option!


All times are GMT. The time now is 11:01 AM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2021, vBulletin Solutions, Inc.