Reply
 
Thread Tools Display Modes
 
Old 06-22-2016, 03:17 AM   #201
New Member
 
Join Date: Jun 2016
Location: GA
Posts: 19
Default Roadtrek Zion -- inverter questions

... But there is a fan or small motor blowing or running under the jump seat when ever I'm plugged into shore power and have the inverter on ... You don't notice the noise if you're watching tv or if the roof air is on, but once the air cycles off then you here the 12v inverter "fan" and it won't stop until you get up and manually flip off the inverter switch.
__________________

GAislandgirl is offline   Reply With Quote
Old 06-22-2016, 03:38 AM   #202
Platinum Member
 
Join Date: Jul 2012
Posts: 1,253
Default

Quote:
Originally Posted by GAislandgirl View Post
... But there is a fan or small motor blowing or running under the jump seat when ever I'm plugged into shore power and have the inverter on ... You don't notice the noise if you're watching tv or if the roof air is on, but once the air cycles off then you here the 12v inverter "fan" and it won't stop until you get up and manually flip off the inverter switch.
Yep, that is the cooling fan in the inverter and you are not the first to find it annoying...
__________________

gregmchugh is offline   Reply With Quote
Old 06-28-2016, 04:41 PM   #203
New Member
 
Join Date: Jun 2016
Location: GA
Posts: 19
Default

Haven't heard the inverter blower fan lately, should I be concerned ???
GAislandgirl is offline   Reply With Quote
Old 06-28-2016, 06:26 PM   #204
Platinum Member
 
Join Date: Jul 2012
Posts: 1,253
Default

Quote:
Originally Posted by GAislandgirl View Post
Haven't heard the inverter blower fan lately, should I be concerned ???
It may only come on when needed to keep it cool.

If everything is working normally I wouldn't worry about it...
gregmchugh is offline   Reply With Quote
Old 06-28-2016, 09:22 PM   #205
New Member
 
Join Date: Mar 2016
Location: Florida
Posts: 6
Default

Yep Greg is right and he is also a wealth of info.... hope to see you on the FB page. We had the same coolant issue with our first Zion. RT replaced the whole Zion. Yes, we are on Zion number 2. I can't believe anyone is still having this issue. When we took delivery on the 1st Zion we drove 14 miles and then had to be flatbedded back to the dealer also!!!!
ZiOsmobile is offline   Reply With Quote
Old 06-29-2016, 12:12 AM   #206
New Member
 
Join Date: Jun 2016
Location: GA
Posts: 19
Default

My new Roadtrek Zion tankless hot water doesn't seem to work. The switch is "on"
The propane is on, the water is connected. When I open a hot water valve, I hear a click but that's it, I let the water keep running but never gets warm. The heat exhaust vent is cold, the red round lite is not on, nor does it ever flash to indicate error. My roof a/c runs and never turns off. Set the thermostat for 86F and it runs and runs, placed a household Mercury thermometer on the sofa, Mercury dropped to 82F. Then I turned off a/c all the way. Pressed the "+" button on the dometic thermostat and read 90F. I am so, so, screwwed.
GAislandgirl is offline   Reply With Quote
Old 06-29-2016, 12:17 AM   #207
New Member
 
Join Date: Jun 2016
Location: GA
Posts: 19
Default

Nobody has offered to give me another RV. The GFCI breaker was tripped and wouldn't reset, GFCI outlets dead. Few days later got the breaker bak into the "on" position, but the little white "test" button won't push in and trip the breaker. I am so, so screeewed.
GAislandgirl is offline   Reply With Quote
Old 06-29-2016, 01:11 AM   #208
Platinum Member
 
Join Date: Jul 2012
Posts: 1,253
Default

If you want the help of a lot of Zion owners you should consider joining the Roadtrek Owners Group on Facebook...
gregmchugh is offline   Reply With Quote
Old 06-29-2016, 01:36 AM   #209
New Member
 
Join Date: Jun 2016
Location: GA
Posts: 19
Default

Quote:
Originally Posted by gregmchugh View Post
If you want the help of a lot of Zion owners you should consider joining the Roadtrek Owners Group on Facebook...
I'll give Facebook a try -- just not fond of Facebook.
This is the third RT I've owned, had a brand new Agile Mercedes Chasis no problems,
Had brand new 190 on a Chev only problem was roof air made water circles on the ceiling in a bad storm got fixed no problem. But the salesman delivered this Zion to m e at my house at 8pm at night to sign all the papers and do the closing. Next morning no coolant, had to get flatbedded which took a week to get appt, got it back home and a lot of things don't work and the soonest appt I can get a RT repair is 7/12. The selling dealership wouldn't give me back my trade, the very next morning after they dropped off the Zion that I had to have flatbedded. Chrysler roadside asst paid to have it towed over an hour away, and it wasn't Chryslers fault it was RT who incorrectly routed hose that caused pulley to rub hole in hose and they didn't use the standoff clamp. And my Zion was made well after RT initial hose re-route problem.
GAislandgirl is offline   Reply With Quote
Old 06-29-2016, 01:58 AM   #210
Platinum Member
 
Join Date: Jul 2012
Posts: 1,253
Default

Quote:
Originally Posted by GAislandgirl View Post
I'll give Facebook a try -- just not fond of Facebook.
This is the third RT I've owned, had a brand new Agile Mercedes Chasis no problems,
Had brand new 190 on a Chev only problem was roof air made water circles on the ceiling in a bad storm got fixed no problem. But the salesman delivered this Zion to m e at my house at 8pm at night to sign all the papers and do the closing. Next morning no coolant, had to get flatbedded which took a week to get appt, got it back home and a lot of things don't work and the soonest appt I can get a RT repair is 7/12. The selling dealership wouldn't give me back my trade, the very next morning after they dropped off the Zion that I had to have flatbedded. Chrysler roadside asst paid to have it towed over an hour away, and it wasn't Chryslers fault it was RT who incorrectly routed hose that caused pulley to rub hole in hose and they didn't use the standoff clamp. And my Zion was made well after RT initial hose re-route problem.
How has the service group at Roadtrek responded to your problems?
__________________

gregmchugh is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Virginia Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3

All times are GMT. The time now is 07:45 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2016, vBulletin Solutions, Inc.