Reply
 
Thread Tools Display Modes
 
Old 04-30-2018, 12:15 PM   #1
Bronze Member
 
Join Date: Jan 2016
Location: Indiana
Posts: 36
Default 12 volt system question in a RoadTrek

I have a 95 Roadtrek 210, the 12 volt system works fine when the generator is running or when the shore power is connected. However, with the engine running I have no 12 volt power. Also when you turn on the battery switch on the wall panel there is no power. Either the battery switch on the panel or the battery disconnect switch is not functioning. With either the gen or shore power on the red LED on the battery switch is on. When you push the battery switch with the engine running or when nothing else is on the red LED does not light, although you hear the battery disconnect switch clunk. If you jumper the battery disconnect switch the 12 volt system comes on. My question is how do you loosen the wall panel from the wall (panel with three switches) From behind I have removed a wall panel. there is a 1" by 2" hole behind the panel filled with wires. I have order a new battery disconnect switch, but I am afraid it is the switch in the wall panel that is bad. I need to loosen the wall panel to investigate and may be to replace the switch or the whole panel. Any help will be appreciated, I really do not want to mess up the panel with all the wires
__________________

95Pop210 is offline   Reply With Quote
Old 04-30-2018, 01:25 PM   #2
New Member
 
Join Date: Dec 2017
Location: Texas
Posts: 18
Default

Any chance your battery bank is bad?
__________________

XLent is offline   Reply With Quote
Old 05-01-2018, 12:34 AM   #3
Bronze Member
 
Join Date: Jan 2016
Location: Indiana
Posts: 36
Default

thanks for your reply, battery is good per Trimetric monitor above 90%. but the good news is I took the disconnect switch apart and cleaned it, every thing working. I am still curious how Roadterk attached the monitor panel to the wall
95Pop210 is offline   Reply With Quote
Old 05-01-2018, 01:12 AM   #4
Platinum Member
 
Join Date: Feb 2016
Location: Portland, Oregon
Posts: 1,275
Default

Is this switch an Inteletec battery relay with a remote switch? And if yes did you clean the relay or the momentary remote switch.
__________________
George
2013 Sprinter VOILA
https://goo.gl/photos/2NCR3teXLSwNYSwN8
GeorgeRa is offline   Reply With Quote
Old 05-01-2018, 04:53 PM   #5
New Member
 
Join Date: Dec 2017
Location: Texas
Posts: 18
Default

Quote:
Originally Posted by 95Pop210 View Post
thanks for your reply, battery is good per Trimetric monitor above 90%. but the good news is I took the disconnect switch apart and cleaned it, every thing working. I am still curious how Roadterk attached the monitor panel to the wall
Ya done good!
XLent is offline   Reply With Quote
Old 05-03-2018, 12:17 AM   #6
Bronze Member
 
Join Date: Jan 2016
Location: Indiana
Posts: 36
Default

The battery disconnect switch is what I cleaned the top is held on with 4 screwws. cleaned the inside and the plates and magnet, wipe with paper towels. Not a lot of carbon but some, any way it works
__________________

95Pop210 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3

All times are GMT. The time now is 06:19 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2019, vBulletin Solutions, Inc.